AccueilCalendrierFAQblogComparateurS'enregistrerConnexion

Partagez | 
 

 Return to Castle Wolfenstein

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : Précédent  1, 2, 3  Suivant
AuteurMessage
yori2004
Master Chief


Messages : 562
Inscrit le : 07/11/2011


Msg n°26 MessageSujet: Re: Return to Castle Wolfenstein Lun 12 Aoû 2013, 11:34

Oui, je l'ai récupéré là-bas. J'arrive à faire fonctionner le jeu une fois les graphismes revus à la baisse. Par contre, le jeu plante toutes les 5 minutes. Une adresse pour tester un autre iso?
Revenir en haut Aller en bas
RatedR57
Team Open Consoles
Team Open Consoles
avatar

Messages : 1369
Réputation : 42
Age : 38
Inscrit le : 16/11/2012

Machine préférée Megadrive, GameBoy et Playstation

Localisation : Tressange (57)

Humeur : Nostalgeek


Msg n°27 MessageSujet: Re: Return to Castle Wolfenstein Lun 12 Aoû 2013, 11:41

Non pas encore mais je vais chercher aujourd hui

________________________________
Eternel Nostalgeek !
Revenir en haut Aller en bas
admin
Ultimate Retrogamer


Messages : 15036
Réputation : 366
Inscrit le : 13/10/2010


Msg n°28 MessageSujet: Re: Return to Castle Wolfenstein Lun 12 Aoû 2013, 17:53


Revenu sur le repo et updaté.

Si vous rencontrez des soucis/questions je peux en parler a ptitseb.
Revenir en haut Aller en bas
yori2004
Master Chief
avatar

Messages : 562
Réputation : 70
Inscrit le : 07/11/2011


Msg n°29 MessageSujet: Re: Return to Castle Wolfenstein Lun 12 Aoû 2013, 18:33

Avec les réglages graphiques au minimum et le driver le plus récent installé, le jeu tourne sans problème. Quand je commence à toucher aux leviers graphiques, les ennuis commencent. Quand tout est à fond, le jeu tourne bien, sauf qu'il plante au bout d'une minute max. Juste en baissant les réglages du nombre de couleurs et de la qualité des textures de 32 à 16 bits, j'ai pu jouer 5 minutes sans problème. J'ai ensuite voulu mettre les éjections de douilles de normales à élevées et le jeu a planté au bout de quelques secondes. J'ai l'impression de jouer à la roulette russe à chaque fois que je lance le jeu, car il plante systématiquement et au bout d'un temps aléatoire n'excédant jamais 5 minutes. Je n'arrive pas à déceler le réglage de trop qui fait tout planter.

C'est assez agaçant car le jeu tourne très bien les réglages à fond et que la configuration de la Pandora est largement supérieure à la configuration recommandée (PIII 750 Mhz, 256 Mo de ram). Le jeu est globalement très beau, propose d'agréables textures, un choix de couleurs et un éclairage réussis. Sans amélioration graphique, il est très fade et perd donc de son charme. Sur les forums officiels, personne ne semble aborder le sujet; ils débattent de la législation allemande quant aux insignes de la seconde guerre mondiale.

Est-ce que Ptitseb pourrait corriger cela et proposer une configuration graphique stable?
Revenir en haut Aller en bas
Caanunoo
PANDORA Addict
PANDORA Addict
avatar

Messages : 945
Réputation : 54
Age : 45
Inscrit le : 11/10/2011

Machine préférée Pandora

Humeur : "Splité" (cf film)


Msg n°30 MessageSujet: Re: Return to Castle Wolfenstein Lun 12 Aoû 2013, 19:16

J'ai récupéré l'iso, l'ai installé sur machine virtuelle(XP), récupéré le dossier "Main" après avoir installé patch 1.41 et renommé "main", puis j'ai télécharger sur le repo "rtcw.pnd", l'ai installé et lancé sur la Pandora 600 Mhz, et enfin placé dossier "main" dans dossier appdata/rtcw.
A noter que j'ai dû supprimer 3 fichiers en .dll du dossier"main", sinon le jeu ne se lançait pas !!!
Résultat, ça tourne nickel, j'ai joué quelques minutes et je n'ai rencontré aucun problème. :top: 
J'y jouerais plus longtemps plus tard pour être sûr.
Au tour de ma Pandora 1 Ghz maintenant.

:fanpandora:
Revenir en haut Aller en bas
ptitSeb
Padawan
avatar

Messages : 169
Réputation : 25
Inscrit le : 12/08/2013


Msg n°31 MessageSujet: Re: Return to Castle Wolfenstein Lun 12 Aoû 2013, 21:13

yori2004 a écrit:
Avec les réglages graphiques au minimum et le driver le plus récent installé, le jeu tourne sans problème. Quand je commence à toucher aux leviers graphiques, les ennuis commencent. Quand tout est à fond, le jeu tourne bien, sauf qu'il plante au bout d'une minute max. Juste en baissant les réglages du nombre de couleurs et de la qualité des textures de 32 à 16 bits, j'ai pu jouer 5 minutes sans problème. J'ai ensuite voulu mettre les éjections de douilles de normales à élevées et le jeu a planté au bout de quelques secondes. J'ai l'impression de jouer à la roulette russe à chaque fois que je lance le jeu, car il plante systématiquement et au bout d'un temps aléatoire n'excédant jamais 5 minutes. Je n'arrive pas à déceler le réglage de trop qui fait tout planter.

C'est assez agaçant car le jeu tourne très bien les réglages à fond et que la configuration de la Pandora est largement supérieure à la configuration recommandée (PIII 750 Mhz, 256 Mo de ram). Le jeu est globalement très beau, propose d'agréables textures, un choix de couleurs et un éclairage réussis. Sans amélioration graphique, il est très fade et perd donc de son charme. Sur les forums officiels, personne ne semble aborder le sujet; ils débattent de la législation allemande quant aux insignes de la seconde guerre mondiale.

Est-ce que Ptitseb pourrait corriger cela et proposer une configuration graphique stable?
Salut.

Bon, déjà, il me faudrait le pndrun_rtcw.out qui ce trouve dans /tmp

Ensuite, au niveau des configs, sur une 1GHz, normalement, il détecte tout seul et installe un fichier config "à fond", avec lumière dynamique et tout le tintoin.
J'ai jouer un peu (style 20 min) et pas eu de plantage, sur une 1GHz (sans overclock particulier), et avec le driver 4.03.00.02.
Cela dis, en terme de perf, c'est le driver par défaut qui fonctionne le mieux, et les artefacts sont peu nombreux dans RtCW (le pire, c'est Enemy Territory).

Sinon, il faudrait que tu efface ton fichier config (juste lui, pour pas perdre tes sauvegardes) et que tu me mette à dispo le pndrun, pour voir c'est bien la bonne config qui est déposé.
Revenir en haut Aller en bas
yori2004
Master Chief
avatar

Messages : 562
Réputation : 70
Inscrit le : 07/11/2011


Msg n°32 MessageSujet: Re: Return to Castle Wolfenstein Lun 12 Aoû 2013, 23:09

Salut,

merci de ta réponse, avant de lire ton message, j'avais effacé les 3 .ddl dont parle Caanunoo et installé la mise-à-jour. J'utilise le même driver que toi. J'ai joué quelques minutes sans problème, ai poussé de nouveau les réglages au maximum et n'en ai toujours pas eu. Du coup, je n'ai pas de pndrun. Je vais continuer de tester et te donnerai ça recommence.
Est-ce que cela viendrait des .ddl que je n'ai pas effacés?

Et bien sûr, merci pour le travail fourni!
Revenir en haut Aller en bas
ptitSeb
Padawan
avatar

Messages : 169
Réputation : 25
Inscrit le : 12/08/2013


Msg n°33 MessageSujet: Re: Return to Castle Wolfenstein Lun 12 Aoû 2013, 23:26

Oui, les dll, elles ne servent à rien sur Pandora, c'est celle de la version PC (mais elle ne devrait pas interférer).
Les fichiers pk3 sont:

Code:

-rwxrwxrwx 1 root root 293887431 2001-11-12 16:20 sp_pak1.pk3
-rwxrwxrwx 1 root root  11026123 2001-11-12 16:27 sp_pak2.pk3
-rwxrwxrwx 1 root root    151931 2002-04-26 14:27 sp_pak3.pk3
Pour vérifier si tu as un fichier corompu, depuis ta Pandora, ouvre un terminal et tape:
Code:

md5sum /media/tonnomdecarteSD/pandora/appdata/rtcw/main/sp*.pk3
évidement, il faut le petit nom de carte SD à la place de tonnomdecarteSD Wink

Si tout est bon, tu dois avoir:

Code:

a0d3fe956f85f40c8efd6babe0d09832  /media/PANDOSEB/pandora/appdata/rtcw/main/sp_pak1.pk3
330b272d5261fe19fcf3c3fbc943c7f3  /media/PANDOSEB/pandora/appdata/rtcw/main/sp_pak2.pk3
00cee7ee80cdb2920322cf37a5f65a11  /media/PANDOSEB/pandora/appdata/rtcw/main/sp_pak3.pk3
Après, au niveau détail graphique, perso, je met les textures en 32bits, les lumières dynamiques, et les texture et détail géométrique en moyen. C'est joli sur le petit écran (surtout les lumière dynamique) et ça bouge plutôt bien.

Tu es bien avec le build 02 (ça ne change pas grand chose au niveau stabilité, mais c'est toujours plus simple pour moi pour débugger).
Revenir en haut Aller en bas
yori2004
Master Chief
avatar

Messages : 562
Réputation : 70
Inscrit le : 07/11/2011


Msg n°34 MessageSujet: Re: Return to Castle Wolfenstein Mar 13 Aoû 2013, 20:31

J'ai continué à jouer hier et le jeu a planté de nouveau de la même manière. Voici le pndout:
[Vous devez être inscrit et connecté pour voir ce lien]

J'utilise bien le build 02. Pour la vérification de fichier corrompu, j'obtiens le même résultat que toi. J'ai effacé le fichier config, recommencé et nouveau plantage après 2 minutes de jeu.
Revenir en haut Aller en bas
ptitSeb
Padawan
avatar

Messages : 169
Réputation : 25
Inscrit le : 12/08/2013


Msg n°35 MessageSujet: Re: Return to Castle Wolfenstein Mar 13 Aoû 2013, 20:47

Heu, très étrange ça. Il n'y a aucun message d'erreur dans le pnd_out (ne pas tenir compte du "X Error of failed request", c'est une erreur normale) ?! Ca donne juste l'impresion que tu es sortie, sauf qu'il n'y a même pas de message de "Shutdown" de GL.
Vraiment étrange. Tu peux essayer de jouer avec un Swap, au cas où ce serait un pb de mémoire. 512 Mo devrait être suffisant.
Revenir en haut Aller en bas
RatedR57
Team Open Consoles
Team Open Consoles
avatar

Messages : 1369
Réputation : 42
Age : 38
Inscrit le : 16/11/2012

Machine préférée Megadrive, GameBoy et Playstation

Localisation : Tressange (57)

Humeur : Nostalgeek


Msg n°36 MessageSujet: Re: Return to Castle Wolfenstein Mar 13 Aoû 2013, 22:35

Ca ne me l'avait pas fait les 2 premières fois mais là ce soir j'ai voulu faire une démo à un de mes neveux et là ça m'a éjecté du jeu au quasi début

________________________________
Eternel Nostalgeek !
Revenir en haut Aller en bas
ptitSeb
Padawan
avatar

Messages : 169
Réputation : 25
Inscrit le : 12/08/2013


Msg n°37 MessageSujet: Re: Return to Castle Wolfenstein Mar 13 Aoû 2013, 23:07

Bon, je ne vois pas. Je vais devoir jouer et trouver un moyen de reproduire le plantage. Je ne l'ai jamais eu, mais je n'ai pas pu jouer plus de 30min d'affiler. J'en suis au niveau du Téléphérique, donc pas très loin encore.

des question pour tout les 2 :
* Quel détails graphiques vous être (texture et géométrie).
* Quel modele de Pandora
* est-ce qu'un Swap est activé ou pas
* version du driver video
Revenir en haut Aller en bas
yori2004
Master Chief
avatar

Messages : 562
Réputation : 70
Inscrit le : 07/11/2011


Msg n°38 MessageSujet: Re: Return to Castle Wolfenstein Mar 13 Aoû 2013, 23:26

Je n'ai pas de swap, je ne vais pas avoir le temps ce soir d'en créer un; je pourrai t'en dire plus demain.

Voici les infos demandées:
* Détails graphiques:
Détails géométriques: élevée
Texture des personnages: extra
Détail des textures: élevée
Filtre des textures: bilinéaire
Compression des textures: yes
Qualité des textures: 32 bits
J'ai aussi changé des paramètres dans Options de jeu:
Durée des marques sur le mur: Normales
Ejection des douilles: Elevée
Eclairage dynamique: yes
Ciel basse qualité: no
Afficher l'horizon: yes
Synchroniser images: yes
Corona dist: Proche
Particules: yes
* Pandora 1 Ghz
* Pas de swap
* Driver 4.03.00.02
Revenir en haut Aller en bas
ptitSeb
Padawan
avatar

Messages : 169
Réputation : 25
Inscrit le : 12/08/2013


Msg n°39 MessageSujet: Re: Return to Castle Wolfenstein Mar 13 Aoû 2013, 23:39

Ok. Effectivement, détails graphique très elevé. C'est peut être bien un problème de mémoire, ça en fait des textures à charger tout ça !

(pour info, "compression des textures", y a pas de code derriere cette option, donc oui/non ne changera rien, idem pour "Synchro des images").

Autre info, pour envoir encore + de détail graphique, va dans le fichier cfg, et change cg_shadows de "1" vers "2" pour avoir des ombres projetées (bon, des fois, c'est pas nickel, styles les assiettes sur les tables ont des ombres, mais pas les tables, surement pour ça qu'il n'y a pas l'option dans l'IHM).

Je pense que, vu la résolution de la Pandora, le "extra" pour les personnage, voir même le "élevée" ne se vois pas vraiment.
De même la géométrie en "haut", par rapport à moyen, je n'ai pas vraiment vu la différence (même si effectivement, une gigahertz arrive à faire bouger ce niveau de détail).
Revenir en haut Aller en bas
yori2004
Master Chief
avatar

Messages : 562
Réputation : 70
Inscrit le : 07/11/2011


Msg n°40 MessageSujet: Re: Return to Castle Wolfenstein Mer 14 Aoû 2013, 00:03

J'essaierai avec un swap demain avec le textures au max, puis en les baissant un peu. Du coup, je viens de me rappeler de bribes d'un message d'erreur que j'ai eu lors des deux premiers plantages. Je revenais au menu et une fenêtre me disait grosso modo "geometric details superior to 8000". En baissant les réglages en moyen, le message est réapparu, puis le plantage du jeu est devenu systématique par rapport au plantage de la partie.
Revenir en haut Aller en bas
ptitSeb
Padawan
avatar

Messages : 169
Réputation : 25
Inscrit le : 12/08/2013


Msg n°41 MessageSujet: Re: Return to Castle Wolfenstein Mer 14 Aoû 2013, 08:31

Si tu as une sauvegarde où le plantage est systèmatique, mets moi-là à disposition, c'est plus facile pour débugger.
Revenir en haut Aller en bas
yori2004
Master Chief
avatar

Messages : 562
Réputation : 70
Inscrit le : 07/11/2011


Msg n°42 MessageSujet: Re: Return to Castle Wolfenstein Mer 14 Aoû 2013, 20:14

Voilà ma sauvegarde:
[Vous devez être inscrit et connecté pour voir ce lien]
Je viens de faire un essai avec un swapfile et le résultat est le même. Je vais baisser les réglages et voir ce que ça donne.
Revenir en haut Aller en bas
ptitSeb
Padawan
avatar

Messages : 169
Réputation : 25
Inscrit le : 12/08/2013


Msg n°43 MessageSujet: Re: Return to Castle Wolfenstein Mer 14 Aoû 2013, 21:00

Ok, je regarde cette sauvegarde. J'ai joué un peu aujourd'hui, je suis sortie du Chateau et suis maintenant dans le village. Aucun problème (mais je suis plutôt en "medium" dans mes réglages, sinon, dans les combats, je trouve que ce n'est pas assez fluide).
Revenir en haut Aller en bas
RatedR57
Team Open Consoles
Team Open Consoles
avatar

Messages : 1369
Réputation : 42
Age : 38
Inscrit le : 16/11/2012

Machine préférée Megadrive, GameBoy et Playstation

Localisation : Tressange (57)

Humeur : Nostalgeek


Msg n°44 MessageSujet: Re: Return to Castle Wolfenstein Mer 14 Aoû 2013, 22:44

Bon ben moi de mon côté j'ai aussi une Pandora 1GHz, après pour les réglages je n'ai absolument rien touché donc je suis avec ceux par défaut. Eventuellement je regarderais plus tard.

________________________________
Eternel Nostalgeek !
Revenir en haut Aller en bas
ptitSeb
Padawan
avatar

Messages : 169
Réputation : 25
Inscrit le : 12/08/2013


Msg n°45 MessageSujet: Re: Return to Castle Wolfenstein Mer 14 Aoû 2013, 23:41

Bon, ok. Il doit rester une fuite ou un ecrasement mémoire quelque part Sad

J'essai de regarder demain (j'ai pas regardé ce soir, je compilais autre chose)...
Revenir en haut Aller en bas
yori2004
Master Chief
avatar

Messages : 562
Réputation : 70
Inscrit le : 07/11/2011


Msg n°46 MessageSujet: Re: Return to Castle Wolfenstein Mer 14 Aoû 2013, 23:55

J'ai réinstallé le driver par défaut. En baissant les réglages en moyen, le problème est toujours là. J'ai téléchargé un autre iso du jeu, le goty de Razor1911. J'ai conservé les réglages moyen, repris ma sauvegarde et ai pu jouer sans problème plusieurs minutes. Ne résistant pas à la tentation, j'ai remis les réglages à fond (ces textures, cet éclairage quand même) et le jeu a de nouveau planté au bout de 30 secondes pendant une scène de combat (je suis au niveau 2, dans la pièce à côté des tonneaux de vin). La scène était chargée, il y avait 4-5 ennemis, le framerate a commencé à chuter et retour au menu de la Pandora.
J'ai relancé une partie en activant le swap et rien n'a changé.

ptitSeb a écrit:
je compilais autre chose
:top:
Revenir en haut Aller en bas
ptitSeb
Padawan
avatar

Messages : 169
Réputation : 25
Inscrit le : 12/08/2013


Msg n°47 MessageSujet: Re: Return to Castle Wolfenstein Jeu 15 Aoû 2013, 00:19

Le plantage semble lié au réglage "à fond" non ?
Revenir en haut Aller en bas
ptitSeb
Padawan
avatar

Messages : 169
Réputation : 25
Inscrit le : 12/08/2013


Msg n°48 MessageSujet: Re: Return to Castle Wolfenstein Jeu 15 Aoû 2013, 11:45

@yori2004, désolé, mais je n'arrive pas a charger ta sauvegarde. Il faudrait que tu fasse une sauvegarde avec un Nom, parce la "current", je ne suis pas sûr de son fonctionnement.
Revenir en haut Aller en bas
yori2004
Master Chief
avatar

Messages : 562
Réputation : 70
Inscrit le : 07/11/2011


Msg n°49 MessageSujet: Re: Return to Castle Wolfenstein Jeu 15 Aoû 2013, 12:07

Je fonctionnais avec une sauvegarde rapide, en voici une avec un nom:
[Vous devez être inscrit et connecté pour voir ce lien]

Sinon, j'ai réessayé avec les réglages les plus faibles et les plantages continuent. Ils se situent rarement dans les couloirs, mais plus dans des pièces plus grandes avec une architecture plus travaillée, des objets, ennemis, etc. Sur les forums officiels, personne n'a rencontré ce problème visiblement. Serait-ce du à l'iso utilisé? Ils ont l'air d'utiliser une image faite à partir de leur propre exemplaire du jeu.
Revenir en haut Aller en bas
admin
Ultimate Retrogamer


Messages : 15036
Réputation : 366
Inscrit le : 13/10/2010


Msg n°50 MessageSujet: Re: Return to Castle Wolfenstein Jeu 15 Aoû 2013, 13:59

Le peu que j'y ai joué, il n'a pas planté. J'utilise une version CD qui date de sa sortie.

Je joue avec ces réglages :

[Vous devez être inscrit et connecté pour voir cette image]

Avec un swap en plus.
Revenir en haut Aller en bas
ptitSeb
Padawan
avatar

Messages : 169
Réputation : 25
Inscrit le : 12/08/2013


Msg n°51 MessageSujet: Re: Return to Castle Wolfenstein Jeu 15 Aoû 2013, 14:52

Je n'ai pas eu de plantage dans mes scéances de jeux, et tu as les même pk3 que moi, tu les as vérifié.

Tu n'overclock pas ta Pandora hein?

J'essaye ta sauvegarde. Essaie les réglages de BAFelton de ton côté, voir si tu as des plantages ou pas.
Revenir en haut Aller en bas
Contenu sponsorisé




Msg n°52 MessageSujet: Re: Return to Castle Wolfenstein

Revenir en haut Aller en bas
 
Return to Castle Wolfenstein
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 2 sur 3Aller à la page : Précédent  1, 2, 3  Suivant

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Communauté Francophone Consoles Open Source et Android - Caanoo GPH / Open Pandora / GCW-Zero ::  :: Forum de la Pandora :: Applications, Hotfixes et Jeux :: Jeux et Portages :: Jeux FPS-